Skip navigation
1 2 Previous Next 10673 Views 15 Replies Latest reply: Nov 8, 2013 8:53 AM by joebaggadonuts RSS
Rookie 9 posts since
Feb 19, 2010

Has received 1 of 9 achievements.
Currently Being Moderated

Jan 17, 2011 8:46 AM

Windows could not parse or process unattend answer file

I am using OSD to deploy Windows 7 Enterprise (captured following Best Known Method guidelines fo Windows 7) I'm using ImageW v2.

 

The problem I'm having is odd and is really frustrating as it is intermittent.

 

After the image has copied down and C:\windows\System32\sysprep\sysprep.exe /oobe /generalize /reboot has run from the auditUser pass, I get a message saying "Windows could not parse or process unattend answer file [C:\Windows\Panther\Unattend.xml]. The answer file is invalid."

 

When I boot into WinPE and open a command prompt (to look at the drive) I can see the Unattend.xml file present at C:\Unattend.xml however there is also a 0 byte Unattend.xml file at C:\Windows\Panther.

 

Some times the file in C:\Windows\Panther is only 40-50 bytes and when I open it with Notepad only the first three or so lines are present (partial copy).

 

The odd part is I can successfully build the computer a handful of times and then the next time get the error and then the next time have it work without making any changes... NOTE: When I get it to build successfully, the correct Unattend.xml file exists in C:\Windows\Panther

 

The only workaround I have is to re-create the OSD task (therefore generating a new XML file) and make the neccessary modifications I need to it e.g. CopyProfile setting, WindowsFeatures setting etc... I can deploy the image ok a handful of times and then the problem returns...

 

Is it possible for an XML file to become corrupted? Is there a log file I can review to see why it isn't downloading properly?

 

Any suggestions are much appreciated.

  • EMiranda Expert 681 posts since
    Aug 26, 2009

    Has received 7 of 9 achievements.

    I have seen in other posts, that the default LANDesk .xml that gets created when doing it through the console was having some issues with certain passes.  To remedy they created their own .xml from the Windows System Image Manager (from WAIK) and point to that one instead of having one created by LANDesk.

  • EMiranda Expert 681 posts since
    Aug 26, 2009

    Has received 7 of 9 achievements.

    Your sysprep logs are here:

     

    Generalize - %WINDIR%\System32\Sysprep\Panther

    Specialize - %WINDIR%\Panther

    Setup actions - %WINDIR%\Panther\Unattendgc

     

     

    you might be able to find out why you are getting the error "Windows could not parse or process unattend answer file [C:\Windows\Panther\Unattend.xml]. The answer file is invalid."

  • steve49423 Apprentice 87 posts since
    Feb 13, 2008

    Has received 3 of 9 achievements.

    OSD will be using an http file download to copy the xml file onto the device you're imaging while its in Winpe.  Have a look at your IIS log file and find the entry in there for the xml - it should show a status of 200 0 0.  If the status is anything else it the problem could be IIS related...

     

    Steve

  • EMiranda Expert 681 posts since
    Aug 26, 2009

    Has received 7 of 9 achievements.

    it seems you are having a problem with IIS for the http download.  As a temporary solution, you could not use http at all.  Just put your xml file on the share where your image or imaging tool is.  You already map to them during the process and just do a good ole copy or move command

     

     

    REMEXEC42=cmd /c move /y i:\imagedirectory\Unattend.xml c:\windows\panther
    
  • EMiranda Expert 681 posts since
    Aug 26, 2009

    Has received 7 of 9 achievements.

    seems as if REMEXEC32 and 33 are redundant and 33 is not needed. I would also change the path to the tokreplw with the unattend.xml that you are actually using.

     

    If you are using your own sysprep, really no need to copy down another one.

     

    REMEXEC31=ldrun x:\cba8\FixWindows.exe
    REMEXEC32=cmd /c copy /y i:\laptop\E4310\SYSPREPD\Unattend.xml c:\windows\panther
    REMEXEC33=ldrun sdclient /f /o /dest="C:\ldsleep.exe" /p="http://%CUSTJOBHOSTIP%/landesk/files/ldsleep.exe", STATUS
    REMEXEC34=ldrun tokreplw C:\windows\panther\unattend.xml COMPUTERNAME=%Computer - Device Name%

  • Reeb Apprentice 98 posts since
    Apr 7, 2008

    Has received 1 of 9 achievements.

    I was having this issue yesterday and I found this thread. I saw it wasn't answered so I wanted to share with you how [I think] I fixed this.

     

    In my Image deployment script, I filled out all of this sysprep stuff so that landesk would create the unattend.xml file.

    I took the deployment-script-name.xml, copied it to the share where my images are stored and renamed it unattend.xml

    Then, in the Pre-Boot Commands section or the deployment script, in the "Enter commands to run before the device is rebooted and imaged" section I entered in: copy "I:\HII\unattend.xml" "c:\windows\panther"

     

    This copies the unattend.xml file from my image share to the panther directory in c:\windows. The next time I tried to deploy the image it worked. Maybe this will help someone else out.

     

    EDIT: nvm, apparently this doesn't work 100% of the time either. oh well. it was worth a shot

    Attachments:
  • jlabomb Rookie 32 posts since
    Apr 11, 2011

    Has received 1 of 9 achievements.

    I was getting this same error but it turned out that the computer name I had chosen was to long for the Unattend File.

  • dbozic Rookie 21 posts since
    Apr 2, 2008

    Has received 1 of 9 achievements.

    Could you check your encoding of working/not working unattend.xml files ?

    unattended_bom_problem.PNG

     

    The shown image is the same Unattend.xml content ! One (left side) saved with no BOM, the right side saved with BOM (in many editors regrettably the default). Left side works, right side not. For BOM just check http://en.wikipedia.org/wiki/UTF-8#cite_note-26 .

    At the beginning it was also to me "a bit strange" that the same file with the same content sometimes works and sometimes not...... I hope that this point helps to solve your problem.

     

    Damir

1 2 Previous Next

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • Correct Answers - 20 points
  • Helpful Answers - 10 points
LANDESK Community powered by Jive SBS® 4.5.7.1  |  Legal Notices  |  Privacy Policy  |  Icon 

TweeterOn Twitter  |  Icon FacebookOn Facebook © 2007 LANDESK Software